<!doctype html>
<html lang="en">

	<head>
		<meta charset="utf-8"/>
		<title>A Good Woman is Hard to Find - Movie Details, Film Cast, Genre & Rating</title>
		<meta NAME="description" CONTENT="Everything you need to know the movie A Good Woman is Hard to Find, including the movie details, film rating, release date, director and cast.">
    <meta property="og:title" content="A Good Woman is Hard to Find"/>
    <meta property="og:type" content="movie"/>
    <meta property="og:site_name" content="FilmJabber.com"/>
    <meta property="fb:admins" content="724366512"/>
    <meta name="twitter:card"       content="summary_large_image" />
  <meta name="twitter:image:alt"  content="A Good Woman is Hard to Find" />
  <meta name="twitter:site"       content="@filmjabber" />
  <meta name="twitter:creator" content="@filmjabber">
<meta name="twitter:title" content="A Good Woman is Hard to Find">
<meta name="twitter:description" content="Everything you need to know the movie A Good Woman is Hard to Find, including the movie details, film rating, release date, director and cast.">
<meta name="twitter:image" content="https://www.filmjabber.com/movie-images/a-good-woman-is-hard-to-find-6588.jpg">
    
    <meta property="og:url" content="https://www.filmjabber.com/movie-preview/a-good-woman-is-hard-to-find.html?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+Movie-sourcecomMovieUpdates+%28Film+Database+Updates+-+FilmJabber%29"/>
    <meta property="og:image" content="https://www.filmjabber.com/movie-images/a-good-woman-is-hard-to-find-6588.jpg"/> 
    <meta property="og:image:width" content="1200"/>
<meta property="og:image:height" content="490"/>
    <link rel="alternate" type="application/rss+xml" href="http://feeds.filmjabber.com/Movie-sourcecomTheatricalReviews-Last20" title="Theatrical Movie Reviews" />
    <link rel="image_src" href="/movie-images/a-good-woman-is-hard-to-find-6588.jpg" />
		<!--[if lt IE 9]>
			<script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script>
		<![endif]-->
    <link href='//fonts.googleapis.com/css?family=Open+Sans' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" media="all" href="/main_styles.css"/>
		<meta name="viewport" content="width=device-width; initial-scale=1"/>
		<!-- Add "maximum-scale=1" to fix the weird iOS auto-zoom bug on orientation changes. -->
		<script src="//ajax.googleapis.com/ajax/libs/jquery/1.4.3/jquery.min.js"></script>
    <script language="JavaScript" src="/js_files/rating.js"></script>
	<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-253755-4', 'auto');
  ga('send', 'pageview');

</script></head>

	<body>
    <div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.3&appId=19224016612&autoLogAppEvents=1"></script>
  	<header>
  <nav id='cssmenu'>
    <div class="logo"><a href="/"><img src="/images/header-logo.gif" alt="FilmJabber"></a></div>
    <div id="head-mobile"></div>
    <div class="button"></div>
    <ul>
      <li><a href='/movies-in-theaters/'>MOVIES</a>
      		<ul>
              <li><a href='/movies-in-theaters/'>Movies in Theaters</a></li>
              <li><a href='/coming-soon/'>Coming Soon</a></li>
              <li><a href='/movie-release-dates/'>Movie Release Dates</a></li>
              <li><a href='/movie-posters/'>Movie Posters</a></li>
      		  <li><a href='/oscars/2019/'>Oscar Nominees</a></li>
              <li><a href='/movie-list/'>Browse by...</a>
                 <ul>
                      <li><a href='/film-genre/'>Film Genre</a></li>
                      <li><a href='/movie-list/'>Movie Title</a></li>
                      <li><a href='/movie-studios/'>Movie Studio</a></li>
                      <li><a href='/movie-database/'>Latest Updates</a></li>
                 </ul>
              </li>
            </ul>
      </li>
       <li><a href='/new-dvd-releases/'>DVD/STREAMING</a>
      		<ul>
              <li><a href='/digital-movie-release-dates/'>Digital Release Dates</a></li>
              <li><a href='/new-dvd-releases/'>Now Available on DVD</a></li>
              <li><a href='/dvd-release-dates/'>Upcoming DVD Releases</a></li>
              <li><a href='/dvd-reviews/'>DVD/Streaming Reviews</a></li>
            </ul>
      </li>
      <li><a href='/movie-reviews/'>REVIEWS</a>
      		<ul>
              <li><a href='/movie-reviews/'>Theatrical Reviews</a></li>
              <li><a href='/dvd-reviews/'>DVD/Streaming Reviews</a></li>
              <li><a href='/movie-ratings/'>Best and Worst</a></li>
              <li><a href='/best-movies-2020/'>Best Movies by Year</a></li>
              <li><a href='/movie-blog/top-10-movie-lists/'>Top 10 Movies List</a></li>
            </ul>
      </li>
      <li><a href='/movie-trailers/'>TRAILERS</a></li>
     
      <li><a href='/movie-blog/'>BLOG</a></li>
      <li><a href='/movie-contests/'>CONTESTS</a></li>
      
      <li class="searchtab"><script>
  (function() {
    var cx = '004584227364352625738:u0ygylwukrm';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></li>
    </ul>
  </nav>
</header>
<div id="leaderboard_ad">
  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-9300182742636543"
     data-ad-slot="6237408957"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>  </div>
<div id="wrapper">        <div id="preview_leftcolumn">
      <div id="movieposter"><a href="/movie-photos/1/a-good-woman-is-hard-to-find.html"><img src="https://www.filmjabber.com/movie-poster-thumbs/a-good-woman-is-hard-to-find-movie-poster-6588.jpg" name="moviePoster" alt="A Good Woman is Hard to Find movie poster" /></a></div>      <div id="ratethemovie">
        <div class="ratingdisplay">
                      <span class="ratingletter">B</span>
                    <br><span class="ratingdescription">FilmJabber</span>
        </div>
        <div class="ratingdisplay">
          						<span class="ratingletter" style="color:#5F5F5F">NA</span>
					          <br><span class="ratingdescription">Users</span>
        </div>
        <div style="clear:both"></div>
        <div class="yourrating">YOUR RATING</div>
        <div>
        <div id="rating_a" class="ratingoption " 
        onclick="redirectToLogin('a-good-woman-is-hard-to-find');">A</div>
         
        <div id="rating_b" class="ratingoption  " 
        onclick="redirectToLogin('a-good-woman-is-hard-to-find');">B</div> 
        
        <div id="rating_c" class="ratingoption " 
        onclick="redirectToLogin('a-good-woman-is-hard-to-find');">C</div> 
        
        <div id="rating_d" class="ratingoption " 
        onclick="redirectToLogin('a-good-woman-is-hard-to-find');">D</div>
         
        <div id="rating_f" class="ratingoption " 
        onclick="redirectToLogin('a-good-woman-is-hard-to-find');">F</div></div>
        <div style="clear:both"></div>
      </div>      <div id="sidenav">
  <a href="/movie-preview/a-good-woman-is-hard-to-find.html" class="sidebar_link">Movie Overview</a>
  <a href="/movie-synopsis/a-good-woman-is-hard-to-find.html" class="sidebar_link">Movie Synopsis</a>
      <a href="/movie-reviews/a-good-woman-is-hard-to-find.html" class="sidebar_link">Movie Review</a>
        <a href="/movie-trailers/a-good-woman-is-hard-to-find.html" class="sidebar_link">Movie Trailers</a>
  </div>      <div id="skyscraper"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-9300182742636543"
     data-ad-slot="0969808758"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
    </div>
		<article>
      <div id="maincolumn">
      
                    <div id="movieimagefeature"><img src="https://www.filmjabber.com/movie-images/a-good-woman-is-hard-to-find-6588.jpg" alt="A Good Woman is Hard to Find" /></div>              <div id="content">
                <div id="movieposter_alternative"><a href="/movie-photos/1/a-good-woman-is-hard-to-find.html"><img src="https://www.filmjabber.com/movie-poster-thumbs/a-good-woman-is-hard-to-find-movie-poster-6588.jpg" name="moviePoster" alt="A Good Woman is Hard to Find movie poster" /></a></div>                <div id="movie_title_info">
                  <h1>A Good Woman is Hard to Find (2020)</h1>
                                    <a href="/crime-thrillers/" title="Crime movies" class="genre_link">Crime</a> <a href="/suspense-thrillers/" title="Suspense movies" class="genre_link">Suspense</a>                   <div class="mpaa">Unrated</div>
                  <div id="runningtime">97 min.</div>
                  <div style="clear:both"></div>
                </div>
                
                <div id="moviedetails">
                  <div class="table_row" style="clear:both">
                    <div class="movie_label">Release Date</div>
                    <div class="movie_info">May 8, 2020 </div>
                  </div>
                                       <div class="table_row" style="clear:both">
                      <div class="movie_label">Digital Date</div>
                      <div class="movie_info">May 8, 2020 </div>
                    </div>
                  									                 
                  <div class="table_row" style="clear:both">
                    <div class="movie_label">Director</div>
                    <div class="movie_info"><a href="/actor/Abner+Pastoll/">Abner Pastoll</a></div>
                  </div>
                  <div class="table_row" style="clear:both;">
                    <div class="movie_label">Writer</div>
                    <div class="movie_info"><a href="/actor/Ronan+Blaney/">Ronan Blaney</a></div>
                  </div>
                  <div class="table_row" style="clear:both;">
                    <div class="movie_label">Cast</div>
                    <div class="movie_info"><a href="/actor/Sarah+Bolger/">Sarah Bolger</a>, <a href="/actor/ Edward+Hogg/"> Edward Hogg</a>, <a href="/actor/ Andrew+Simpson /"> Andrew Simpson </a></div>
                  </div>
                  <div class="table_row" style="clear:both;">
                    <div class="movie_label">Studio</div>
                    <div class="movie_info"><a href="/movie-studios/Film-Movement /" title="Film Movement movie">Film Movement</a></div>
                  </div>
                  <div class="table_row" style="clear:both;">
                    <div class="movie_label">Running Time</div>
                    <div class="movie_info">97 minutes</div>
                  </div>
                  <div class="table_row" style="clear:both;">
                    <div class="movie_label">MPAA Rating</div>
                    <div class="movie_info">Unrated</div>
                  </div>
                </div>
                <div style="clear:both"></div>
                
                <div id="moviesummary">
									<p><p>A recently widowed young mother goes to incredible lengths to protect her children as she seeks the truth behind her husband&#39;s murder.</p>...
            			<strong><a href="/movie-synopsis/a-good-woman-is-hard-to-find.html">Full synopsis &raquo;</a></strong></p>
                </div>
                <h2><a href="/movie-reviews/a-good-woman-is-hard-to-find.html">MOVIE REVIEW</a></h2>
                <div>
											 <strong>A Good Woman is Hard to Find</strong>, according to director Abner Pastoll. I suppose it depends on your definition.

                  <strong><a href="/movie-reviews/a-good-woman-is-hard-to-find.html">Full movie review &raquo;</a></strong>
                              		</div>
                
       					
              </div>
              <div id="preview_altnav">
                <div id="ratethemovie">
        <div class="ratingdisplay">
                      <span class="ratingletter">B</span>
                    <br><span class="ratingdescription">FilmJabber</span>
        </div>
        <div class="ratingdisplay">
          						<span class="ratingletter" style="color:#5F5F5F">NA</span>
					          <br><span class="ratingdescription">Users</span>
        </div>
        <div style="clear:both"></div>
        <div class="yourrating">YOUR RATING</div>
        <div>
        <div id="rating_a" class="ratingoption " 
        onclick="redirectToLogin('a-good-woman-is-hard-to-find');">A</div>
         
        <div id="rating_b" class="ratingoption  " 
        onclick="redirectToLogin('a-good-woman-is-hard-to-find');">B</div> 
        
        <div id="rating_c" class="ratingoption " 
        onclick="redirectToLogin('a-good-woman-is-hard-to-find');">C</div> 
        
        <div id="rating_d" class="ratingoption " 
        onclick="redirectToLogin('a-good-woman-is-hard-to-find');">D</div>
         
        <div id="rating_f" class="ratingoption " 
        onclick="redirectToLogin('a-good-woman-is-hard-to-find');">F</div></div>
        <div style="clear:both"></div>
      </div>                <div id="sidenav">
  <a href="/movie-preview/a-good-woman-is-hard-to-find.html" class="sidebar_link">Movie Overview</a>
  <a href="/movie-synopsis/a-good-woman-is-hard-to-find.html" class="sidebar_link">Movie Synopsis</a>
      <a href="/movie-reviews/a-good-woman-is-hard-to-find.html" class="sidebar_link">Movie Review</a>
        <a href="/movie-trailers/a-good-woman-is-hard-to-find.html" class="sidebar_link">Movie Trailers</a>
  </div>              </div>
              <div id="content" style="padding-top:0px">
								
<div class="clearDiv"></div>

<div class="fb-comments" data-href="https://www.filmjabber.com/movie-preview/a-good-woman-is-hard-to-find.html" data-width="" data-numposts="10"></div>






              </div>
										
      	
      </div>
      
		</article>		 
		<div id="rightcolumn">
  <div id="social_media_right">
    <a href="http://www.facebook.com/filmjabber" target="_blank"><img src="/images/button-facebook.gif"></a>
    <a href="http://twitter.com/filmjabber" target="_blank"><img src="/images/button-twitter.gif"></a>
    <div style="clear:both"></div>
  </div>
  <div id="ad_square"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-9300182742636543"
     data-ad-slot="1340445128"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
  
        
  <div id="new_content">
    <div id="new_content_title">MOVIE FEATURES</div>    
    	
            
          <div class="new_content_block">
            <a href="https://www.filmjabber.com/movie-reviews/high-note.html"><img src="https://www.filmjabber.com/movie-images/high-note-6560.jpg" alt="Review: 'The High Note' Finds a Familiar Beat"></a>
            <a href="https://www.filmjabber.com/movie-reviews/high-note.html" class="new_content_text_link">Review: 'The High Note' Finds a Familiar Beat</a>
          </div>
      
            
          <div class="new_content_block">
            <a href="https://www.filmjabber.com/movie-trailers/tenet.html"><img src="https://www.filmjabber.com/movie-images/tenet-6496.jpg" alt="Watch the Second 'Tenet' Trailer"></a>
            <a href="https://www.filmjabber.com/movie-trailers/tenet.html" class="new_content_text_link">Watch the Second 'Tenet' Trailer</a>
          </div>
      
            
          <div class="new_content_block">
            <a href="https://www.filmjabber.com/movie-trailers/relic-2020.html"><img src="https://www.filmjabber.com/movie-images/relic-2020-6591.jpg" alt="Check out the Creepy New  'Relic' Teaser"></a>
            <a href="https://www.filmjabber.com/movie-trailers/relic-2020.html" class="new_content_text_link">Check out the Creepy New  'Relic' Teaser</a>
          </div>
      
            
          <div class="new_content_block">
            <a href="https://www.filmjabber.com/movie-reviews/the-lovebirds.html"><img src="https://www.filmjabber.com/movie-images/the-lovebirds-6484.jpg" alt="'The Lovebirds' is Bad Comedy"></a>
            <a href="https://www.filmjabber.com/movie-reviews/the-lovebirds.html" class="new_content_text_link">'The Lovebirds' is Bad Comedy</a>
          </div>
      
            <div style="clear:both"></div>  
  </div>
  </div>		
    <footer>
  <div style="clear:both"></div>
  <div id="footer">
    <a href='/' title='Movies'>Home</a> |
    <a href='/movies-in-theaters/' title='Movies'>Movies</a> |
    <a href='/movie-reviews/' title='Movies'>Movie Reviews</a> |
    <a href='/movie-trailers/' title='Movies'>Trailers</a> |
    <a href='/new-dvd-releases/' title='Movies'>DVD</a> |
    <a href='/movie-blog/' title='Movie blog'>Blog</a> |
    <a href='/movie-contests/' title='Movies'>Contests</a> |
    <a href='/about/' title='' rel="nofollow">About Us</a> |
    <a href='/about/' title='' rel="nofollow">Help</a> |
    <a href='/contact/' title='' rel="nofollow">Contact Us</a>&nbsp;&nbsp;&nbsp;<a href="/rss-movie-feeds/" title="Movie RSS feeds"><img src="/images/rss.gif" width="36" height="14" border="0" alt="Movie RSS feeds"></a><br />
    Movie reviews &copy; 2003-2020 <a href='http://www.eriksamdahl.com' title='Suspense fiction author' target='_blank'>Erik Samdahl</a>. All other content &copy; of its respected owner. Read our <a href="/privacy/" rel="nofollow">privacy policy</a>.<br />FilmJabber is a client of this <a href="http://www.garthobrien.com/" target="_blank">SEO Consultant</a>.
  </div>
</footer>
</div><!--end wrapper-->

<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-aaAD5bLbPREZo"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-aaAD5bLbPREZo.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->	
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
    <script src="/site_includes/dropdown.js"></script>																																		
	</body>
</html>

